Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Compile Error on 1st use, sketch does compile in Arduino IDE (Read 96 times)
arduino_al
Newbies
*
Offline



Posts: 2
Texas
Compile Error on 1st use, sketch does compile in Arduino IDE
Dec 1st, 2018 at 2:20am
 
Please Help With a Compile error on 1st installation and use of AtmelStudio V7 and Visual Micro for Arduino Uno on Windows 10.  This sketch does compile and runs correctly using the Arduino IDE.  There appears to be a missing bin directory. I reinstalled the arduino IDE and the bin directory is still missing.  The path looking for the directory is the "Architecture Tools:' in the compile output attached.  this path c:/Users/almoo/AppData/..../tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/    but no /bin/ folder exists.  Deep search cannot find the file avr-g++

What am i missing?  Thanks in advance
Al
Back to top
 

Compile_error.txt (2 KB | 0 )
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 9493
United Kingdom
Re: Compile Error on 1st use, sketch does compile in Arduino IDE
Reply #1 - Dec 1st, 2018 at 2:42am
 
Thanks for the info.

It sounds like you have a partial install of hardware via Board Manager

If using avr then it comes with the arduino ide so you don't need board manager

Remove this folder: This removes all the board manager downloaded packages.

c:/Users/almoo/AppData/Local/Arduino15/packages


or remove this folder: This removes any "arduino" packages that were downloaded with board manager

c:/Users/almoo/AppData/Local/Arduino15/packages/arduino

or remove this folder then restart the arduino ide: Removes all packages and package index files from board manager

c:/Users/almoo/AppData/Local/Arduino15

note

All board manager packages can be re-downloaded at any time therefore removing the above folders does not destroy anything useful

Restart Visual Micro (IDE) after making changes or click the Rescan command
Back to top
« Last Edit: Dec 1st, 2018 at 2:43am by Visual Micro »  
WWW  
IP Logged
 
arduino_al
Newbies
*
Offline



Posts: 2
Texas
Re: Compile Error on 1st use, sketch does compile in Arduino IDE
Reply #2 - Dec 1st, 2018 at 2:59am
 
That worked beautifully, thanks so much
Al
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print