Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Libraries not recognised - Visual Studio 2019 (Read 92 times)
Foxster
Newbies
*
Offline



Posts: 2
Libraries not recognised - Visual Studio 2019
Sep 17th, 2020 at 2:39pm
 
Hi,

For some reason libraries are not recognised (no intellisense) yet the project seems to compile.

1. Create empty project
2) Add #include <Adafruit_NeoPixel.h>
3)
Adafruit_NeoPixel strip(LED_NUMBER, LED_DATA_PIN, NEO_GRB + NEO_KHZ800);

Code is underlined in red, constants are imported. When looking at the header file Adafruit_NeoPixel.h, which is listed as an external dependancy, all of the uint16_t etc are underlined in red also?

Install seems fine.

Thanks,
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Online



Posts: 537
Re: Libraries not recognised - Visual Studio 2019
Reply #1 - Sep 17th, 2020 at 2:47pm
 
Would it be possible to attach the build log with the options set as shown at the top of the page, for verbose and show build properties?
Back to top
 
 
IP Logged
 
Foxster
Newbies
*
Offline



Posts: 2
Re: Libraries not recognised - Visual Studio 2019
Reply #2 - Sep 17th, 2020 at 3:21pm
 
Please see attached.

thanks,
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print