Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Arduino Due "uploader process failed" (Read 90 times)
BrandonVanPelt
Newbies
*
Offline



Posts: 4
Arduino Due "uploader process failed"
Nov 16th, 2020 at 10:34pm
 
I've been using visual micro with the Mega2560 for over 6 months now. I just bought a Due, setup a new project but can't upload to the board. Programming port is plugged in and selected in vMicro and I am using the right COM port.

Uploading 'ControlBoxDue' to 'Arduino Due (Programming Port)' using 'COM9'
The uploader process failed
bossac.exe: extra arguments found
Try 'bossac.exe -h' or 'bossac.exe --help' for more information

Error list is attached. It starts to program or at least it erases the due because I loose what is on there from Arduino IDE but then it throws the error and will not program. There is no problem programming it with Arduino IDE.

Anyone have any ideas of what could be causing this to happen?
Back to top
« Last Edit: Nov 16th, 2020 at 11:55pm by BrandonVanPelt »  

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Online



Posts: 537
Re: Arduino Due "uploader process failed"
Reply #1 - Nov 16th, 2020 at 10:46pm
 
Thanks for the report. 

Would it be possible to upload the logging from the Output window for;
1) a build, with the settings enabled as shown at the top of this page?
2) the upload with the vMicro > Uploader > Verbose setting enabled?
Back to top
 
 
IP Logged
 
BrandonVanPelt
Newbies
*
Offline



Posts: 4
Re: Arduino Due "uploader process failed"
Reply #2 - Nov 17th, 2020 at 1:39am
 
Build properties and verbose enabled.
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Online



Posts: 537
Re: Arduino Due "uploader process failed"
Reply #3 - Nov 17th, 2020 at 12:14pm
 
Thanks for the detail around this, and there have been some fixes to this area since the version you have installed.

Would it be possible to upgrade to the latest Visual Micro (from the Extensions in VS, or the Forum Page), and retry the process?
Back to top
 
 
IP Logged
 
BrandonVanPelt
Newbies
*
Offline



Posts: 4
Re: Arduino Due "uploader process failed"
Reply #4 - Nov 17th, 2020 at 1:32pm
 
The update fixed the problem. Thank you! Worth noting though, the errors still seem to show up, they just don't stop the upload.
Back to top
« Last Edit: Nov 17th, 2020 at 1:38pm by BrandonVanPelt »  

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
BrandonVanPelt
Newbies
*
Offline



Posts: 4
Re: Arduino Due "uploader process failed"
Reply #5 - Nov 17th, 2020 at 1:41pm
 
Output after update, I'll leave here incase you want it. At least I can upload now.
Back to top
« Last Edit: Nov 17th, 2020 at 1:42pm by BrandonVanPelt »  

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print