Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 

Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
STM32F103C8 debug help (Read 514 times)
msafar
Junior Member
**
Offline



Posts: 12
STM32F103C8 debug help
Mar 7th, 2022 at 10:36am
 
Board: STM32F103C8
Ide: Visual Studio + Visual Micro
Programmer and debugger external ST-Link v2.
The compiled program loads successfully, but the "Attach to Process" menu item stops with an error message.
I have attached the appropriate files.
What else do I need to do to start debugging?

Regards: Safar Miklos
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1575
Re: STM32F103C8 debug help
Reply #1 - Mar 7th, 2022 at 11:39am
 
Thanks for the report, could you attach the below file for us to review:
Code:
C:\Users\Cnc\AppData\Local\Temp\VMBuilds\STblink\stm32duino_genericSTM32F103C\Debug/STblink.ino_DebugOpenOCD.log 

Back to top
 
 
IP Logged
 
msafar
Junior Member
**
Offline



Posts: 12
Re: STM32F103C8 debug help
Reply #2 - Mar 7th, 2022 at 11:48am
 
I attached.
Thanks.
Safar Miklos
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1575
Re: STM32F103C8 debug help
Reply #3 - Mar 7th, 2022 at 2:11pm
 
Thanks for the detail, this appears to be the result of the board containing an unofficial chip.

If you add a local board.txt to the project (vMicro > Add Code > Add Local Board.txt) and add the below lines to it, then try attaching the debugger again it should work:
Code:
tools.stlinkv2.server.targetCmd=-c set CPUTAPID 0x2ba01477 -f "{tools.openocd.debug.build.openocdscript}"
tools.stlinkv2.upload.targetCmd=-c set CPUTAPID 0x2ba01477 -f "{tools.openocd.upload.openocdscript}" 

Back to top
 
 
IP Logged
 
msafar
Junior Member
**
Offline



Posts: 12
Re: STM32F103C8 debug help
Reply #4 - Mar 7th, 2022 at 6:44pm
 
Thanks for the tip.
I tried, but unfortunately there is still an error message that the process is over.
I attached the files (4 files)

Thank you and look forward to further solutions:

Safar Miklos
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
msafar
Junior Member
**
Offline



Posts: 12
Re: STM32F103C8 debug help
Reply #5 - Mar 7th, 2022 at 6:45pm
 
2 more files.

Safar Miklos
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1575
Re: STM32F103C8 debug help
Reply #6 - Mar 7th, 2022 at 7:08pm
 
Apologies, I had missed the quotes around the command, these should be:
Code:
tools.stlinkv2.server.targetCmd=-c "set CPUTAPID 0x2ba01477" -f "{tools.openocd.debug.build.openocdscript}"
tools.stlinkv2.upload.targetCmd=-c "set CPUTAPID 0x2ba01477" -f "{tools.openocd.upload.openocdscript}"  

Back to top
 
 
IP Logged
 
msafar
Junior Member
**
Offline



Posts: 12
Re: STM32F103C8 debug help
Reply #7 - Mar 7th, 2022 at 7:19pm
 
Dear Simon!

You are big !
Thank you so much for your help, and thank you so much for helping me even at 7 p.m.
With the add-on sent, debug WORKS!
Thanks again for everything:

Miklos Smiley
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print