Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic How can i change VECT_TAB_OFFSET? (Read 2560 times)
stnih07
Newbies
*
Offline


Posts: 7
Joined: Dec 20th, 2015
How can i change VECT_TAB_OFFSET?
May 17th, 2019 at 10:20am
Print Post  
Hi,
I am using Visual Micro for Arduino_Core_STM32 with STM32F4-DISCO1. 

Arduino works fine with IDE when I add "Disco.build.extra_flags" in the board.txt file. But when I compile with Visual Micro, there's no change. And no errors What would be the reason?
« Last Edit: May 17th, 2019 at 10:22am by stnih07 »  

Please Register or Login to the Forum to see File Attachments
Back to top
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline


Posts: 11676
Location: United Kingdom
Joined: Apr 10th, 2010
Re: How can i change VECT_TAB_OFFSET?
Reply #1 - May 17th, 2019 at 1:14pm
Print Post  
Did you click Re-Scan or Re-Start the ide after making the external change?

To review issues like this we need the info requested at the top of the forum. This will answer any questions.
  
Back to top
WWW  
IP Logged
 
stnih07
Newbies
*
Offline


Posts: 7
Joined: Dec 20th, 2015
Re: How can i change VECT_TAB_OFFSET?
Reply #2 - May 17th, 2019 at 1:45pm
Print Post  
Yes, I tried both.
  

Please Register or Login to the Forum to see File Attachments
Back to top
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline


Posts: 11676
Location: United Kingdom
Joined: Apr 10th, 2010
Re: How can i change VECT_TAB_OFFSET?
Reply #3 - May 17th, 2019 at 3:11pm
Print Post  
Thanks for the output. you also need to switch on the compiler>verbose or I can't see exactly which board and option has been selected. There are some changes to extra flags in your core depending on the board options so I need to see the compiler output.

Thanks
  
Back to top
WWW  
IP Logged
 
stnih07
Newbies
*
Offline


Posts: 7
Joined: Dec 20th, 2015
Re: How can i change VECT_TAB_OFFSET?
Reply #4 - May 17th, 2019 at 3:21pm
Print Post  
Thanks for your quick answers. I added the output.
  

Please Register or Login to the Forum to see File Attachments
Back to top
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline


Posts: 11676
Location: United Kingdom
Joined: Apr 10th, 2010
Re: How can i change VECT_TAB_OFFSET?
Reply #5 - May 17th, 2019 at 4:06pm
Print Post  
Thanks, we can see the VECT_TAB_OFFSET is correct in the compiler output.

Please switch off "vMicro>Compiler>Shared Cache For Cores". Maybe the core cache is not being release correctly when you changed the extra flags. We will look into it but switching it off should resolve.   

With this option switched off you will have a core built for each project which is cleaner when changing global compiler settings.

If still an issue then then click "Build.Clean Solution" which cleans the project build cache.

« Last Edit: May 17th, 2019 at 4:07pm by Tim@Visual Micro »  
Back to top
WWW  
IP Logged
 
stnih07
Newbies
*
Offline


Posts: 7
Joined: Dec 20th, 2015
Re: How can i change VECT_TAB_OFFSET?
Reply #6 - May 17th, 2019 at 9:43pm
Print Post  
I've tried the way you write. it worked this way. Thanks..
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint