Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Serial debugger stuck on "Launching debugger..." (Read 141 times)
Isaac
Newbies
*
Offline



Posts: 3
Serial debugger stuck on "Launching debugger..."
May 20th, 2020 at 8:15pm
 
I tried to search for other posts about this same issue but none of the threads had applicable solutions.

I have an Due. I have successfully uploaded a number of sketches. The serial output from these sketches comes through to the monitor no problem. However, I have been unable to get debugging to work. When I switch to debug mode and click build and upload, everything seems to go fine but the micro debug trace output simply shows Launching Debugger... (along with some tutorial text when I have tutorial mode on).

In order to reduce confounding factors, I'm following the debugging tutorial.

I am using the native usb port on the due.
Back to top
 

DebugBuildLog.txt (99 KB | 5 )
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10653
United Kingdom
Re: Serial debugger stuck on "Launching debugger..."
Reply #1 - May 21st, 2020 at 12:30am
 
If your own sketch code uses serial then please make sure you have set the speed that you use in vMicro>Debugger>RemoteSpeed. That should also change the LocalSpeed menu item to be the same.

Please also ensure the DTR on the serial monitor is enabled otherwise any breakpoints in setup() might be missed.

If those two points don't help then please confirm if you own code uses Serial.read() and an example of where you have placed a breakpoint.

Thanks

Back to top
 
WWW  
IP Logged
 
Isaac
Newbies
*
Offline



Posts: 3
Re: Serial debugger stuck on "Launching debugger..."
Reply #2 - May 21st, 2020 at 12:56am
 
I'm trying the debugger on the "Blink without delay" example sketch which doesn't use serial at all. I set the breakpoint on the loop function declaration (as the tutorial instructed).

Since you mentioned it, DTR doesn't seem to work. Is it supposed to reset my board when I deselect and reselect 'connect'?.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10653
United Kingdom
Re: Serial debugger stuck on "Launching debugger..."
Reply #3 - May 23rd, 2020 at 1:00pm
 
Some boards don't use the DTR, the Native USB Port is one of them.

Bacause you are usig the native usb port on a due I think I recall that it uses Serial1 and not Serial for that port.

In that case set "vMicro>Debugger>Remote Port" to Serial1. See if that works?

(We should be detecting that and switching to Serial1 but maybe that detection is failing)



Back to top
 
WWW  
IP Logged
 
Isaac
Newbies
*
Offline



Posts: 3
Re: Serial debugger stuck on "Launching debugger..."
Reply #4 - May 25th, 2020 at 5:07pm
 
That pointed me in the right direction. Overriding the remote port to serial1 didn't work but overriding to SerialUSB did.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10653
United Kingdom
Re: Serial debugger stuck on "Launching debugger..."
Reply #5 - May 25th, 2020 at 5:35pm
 
Thanks, we will look into that. It should auto detect SerialUSB for that board unless you specifically set the RemotePort.

Back to top
 
WWW  
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 246
Re: Serial debugger stuck on "Launching debugger..."
Reply #6 - May 27th, 2020 at 8:42pm
 
The Latest Release (20.05.18.5) contains a fix for this issue, let us know if there are any further problems.

Previous Releases, New Releases and Notifications
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print